dart_browser_loader 0.0.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 73

dart_browser_loader

Import Javascript/Css... using Dart

await loadScript("https://code.jquery.com/jquery-3.2.1.min.js");
await loadLink("https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css");
await loadInlineStyle('''
  body {
    color: red;
  }
  ''');

It will add following element to dom.

<script type="text/javascript" async="" src="https://code.jquery.com/jquery-3.2.1.min.js"></script>
<link type="text/css" rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css">
<style>  body {
    color: red;
  }
 </style>

All function return future with element when link is valid or throw an error when invalid.

Changelog

0.0.5

  • dart 2 stable

0.0.4

  • support inline script

0.0.3

  • better performance
  • fix blocking load when call multiple time

0.0.2

  • add defer to loadScript

0.0.1

  • Initial version, created by Stagehand

example/main.dart

import '../lib/dart_browser_loader.dart';

main() async {
  await loadScript("https://code.jquery.com/jquery-3.2.1.min.js");
  await loadLink(
      "https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css");
  await loadInlineStyle('''
  body {
    color: red;
  }
  ''');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_browser_loader: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_browser_loader/dart_browser_loader.dart';
  
Version Uploaded Documentation Archive
0.0.5 Aug 6, 2018 Go to the documentation of dart_browser_loader 0.0.5 Download dart_browser_loader 0.0.5 archive
0.0.4 Feb 6, 2018 Go to the documentation of dart_browser_loader 0.0.4 Download dart_browser_loader 0.0.4 archive
0.0.3 Jan 17, 2018 Go to the documentation of dart_browser_loader 0.0.3 Download dart_browser_loader 0.0.3 archive
0.0.2 Dec 21, 2017 Go to the documentation of dart_browser_loader 0.0.2 Download dart_browser_loader 0.0.2 archive
0.0.1 Dec 20, 2017 Go to the documentation of dart_browser_loader 0.0.1 Download dart_browser_loader 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
64
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: web

Primary library: package:dart_browser_loader/dart_browser_loader.dart with components: html.

Health issues and suggestions

Document public APIs (-10 points)

5 out of 5 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
Dev dependencies
test ^1.3.0