dart_browser_loader 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 86

dart_browser_loader

Import Javascript/Css... using Dart

await loadScript("https://code.jquery.com/jquery-3.2.1.min.js");
await loadLink("https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css");
await loadInlineStyle('''
  body {
    color: red;
  }
  ''');

It will add following element to dom.

<script type="text/javascript" async="" src="https://code.jquery.com/jquery-3.2.1.min.js"></script>
<link type="text/css" rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css">
<style>  body {
    color: red;
  }
 </style>

All function return future with element when link is valid or throw an error when invalid.

Changelog

0.0.1

  • Initial version, created by Stagehand

example/main.dart

import 'package:dart_browser_loader/dart_browser_loader.dart';

main() async {

  await loadScript("https://code.jquery.com/jquery-3.2.1.min.js");
  await loadLink("https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css");
  await loadInlineStyle('''
  body {
    color: red;
  }
  ''');

}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_browser_loader: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:dart_browser_loader/dart_browser_loader.dart';
  
Version Uploaded Documentation Archive
0.0.4 Feb 6, 2018 Go to the documentation of dart_browser_loader 0.0.4 Download dart_browser_loader 0.0.4 archive
0.0.3 Jan 17, 2018 Go to the documentation of dart_browser_loader 0.0.3 Download dart_browser_loader 0.0.3 archive
0.0.2 Dec 21, 2017 Go to the documentation of dart_browser_loader 0.0.2 Download dart_browser_loader 0.0.2 archive
0.0.1 Dec 20, 2017 Go to the documentation of dart_browser_loader 0.0.1 Download dart_browser_loader 0.0.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
72 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
86
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:dart_browser_loader/dart_browser_loader.dart with components: html.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Run dartfmt to format lib/dart_browser_loader.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
browser ^0.10.0+2 0.10.0+3
Dev dependencies
test ^0.12.0