Create Dart + React apps with no build configuration.
pub global activate dart_create_react_app export PATH=$PATH:~/.pub-cache/bin dart_create_react_app my_app cd my_app/ pub serve
Then open http://localhost:8080/ to see your app.
When you’re ready to deploy to production, create a minified bundle with
You don’t need to install or configure any extra tooling. They are preconfigured so that you can focus on the code.
Just create a project, and you’re good to go.
If you don't already have Dart installed, you can install using Homebrew on macOS.
$ brew tap dart-lang/dart $ brew install dart --with-content-shell --with-dartium
Then, you can install dart_create_react_app globally.
pub global activate dart_create_react_app export PATH=$PATH:~/.pub-cache/bin
To create a new app, run:
dart_create_react_app my_app cd my_app/
It will create a directory called
my_app inside the current folder.
Inside that directory, it will generate the initial project structure and install the transitive dependencies:
my_app/ ├── lib/ │ └── src/ │ | └── my_app │ | | └── app.dart │ └── my_app.dart ├── tool/ ├── test/ │ └── unit/ │ | └── my_app │ | | └── my_app_test.dart ├── web/ │ └── main.dart │ └── index.css │ └── index.html │ └── logo.svg ├── .gitignore ├── pubspec.lock ├── pubspec.yaml └── README.md
No configuration or complicated folder structures, just the files you need to build your app. Once the installation is done, you can run some commands inside the project folder:
Runs the app in development mode.
Open http://localhost:8080 to view it in the browser.
pub run dart_dev test
Runs all tests located in the
Builds the app for production to the
It correctly bundles React in production mode and optimizes the build for the best performance.
You can install the package from the command line:
$ pub global activate dart_create_react_app
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: dart_create_react_app: ^1.0.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.0||Nov 25, 2017|
|0.4.0||Nov 25, 2017|
|0.3.2||Nov 24, 2017|
|0.3.1||Nov 24, 2017|
|0.3.0||Nov 24, 2017|
|0.2.0||Nov 24, 2017|
|0.1.1||Nov 24, 2017|
|0.1.0||Nov 24, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.23.0 <2.0.0|