dart_data_io 0.0.1

  • README.MD
  • Installing
  • Versions
  • 38

A library for reading and writing data input streams (similar to Java's DataInputStream and DataOutputStream). Based on dart_io but with (1) Fix end-of-steam bug in readBytes(); (2) readLong() and writeLong() use ints, not arrays

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_data_io: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_data_io/dart_io.dart';

import 'package:dart_data_io/data_input.dart';

import 'package:dart_data_io/data_output.dart';

import 'package:dart_data_io/helpers.dart';
        
Version Uploaded Documentation Archive
0.0.1 Dec 4, 2017 Go to the documentation of dart_data_io 0.0.1 Download dart_data_io 0.0.1 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
76 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
75 / 100
Overall score:
Weighted score of the above. [more]
38
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Use constrained dependencies.

    The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: archive, fixnum.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 48 hints.

    Run dartfmt to format lib/dart_io.dart.

    Strong-mode analysis of lib/data_input.dart gave the following hint:

    line: 122 col: 40
    'Endianness' is deprecated and shouldn't be used.

    Similar analysis of the following files failed:

    • lib/data_output.dart (hint)
    • lib/helpers.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dart_data_io.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
archive any 1.0.33
fixnum any 0.10.7
Transitive dependencies
args 1.4.2
charcode 1.1.1
collection 1.14.9
convert 2.0.1
crypto 2.0.2+1
path 1.5.1
typed_data 1.1.5