Add this to your package's pubspec.yaml file:
dependencies: dart_irc: ^0.1.3
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.3||Mar 28, 2017|
|0.1.2||Mar 28, 2017|
|0.1.1||Mar 28, 2017|
|0.1.0||Mar 28, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, other
Platform components identified in package:
Changelog entries help clients to follow the progress in your code.
Add SDK constraint in
For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.
Readme should inform others about your project, what it does, and how they can use it.
Package is getting outdated.
The package was released 71 weeks ago.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction of the API.
Maintain an example.
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
dartfmt to format
dartfmt to format
Fix additional 3 files with analysis or formatting issues.
Additional issues in the following files: