dart_repl 0.10.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 1

dart_repl #

A proof of concept REPL environment for Dart.

asciicast

See the Dart REPL Directions brain-dump for possible ideas and directions.

Usage #

Using pub global run

You can install and setup dart_repl using:

pub global activate dart_repl

To run it, simply execute:

pub global run dart_repl

If you run it from a directory that contains a Dart package (it needs a .packages file), it will load all dependencies automatically and allow you to import libraries adhoc:

pub global run dart_repl --adhoc-import package:built_collection/built_collection.dart

(if your package depends on built_collection).

This is the preferred way of running dart_repl as it requires no additional setup.

From another package #

You can add a dev_dependency: to your pubspec.yaml:

dev_dependencies:
  dart_repl:
  [...]

You can then run the REPL with:

pub run dart_repl

It will automatically resolve all additional adhoc imports against the dependencies of your package:

pub run dart_repl --adhoc-import package:built_collection/built_collection.dart

From a checkout #

From the command-line

dart bin/dart_repl.dart

To import additional libraries, you need to specify a package directory (--package-dir) to allow it to resolve dependencies:

dart bin/dart_repl.dart --package-dir ~/git/built_collection.dart/ --adhoc-import lib/built_collection.dart

Features requests and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.1 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_repl: ^0.10.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_repl/dart_repl.dart';
  
Version Uploaded Documentation Archive
0.11.1 Apr 19, 2017 Go to the documentation of dart_repl 0.11.1 Download dart_repl 0.11.1 archive
0.11.0 Apr 19, 2017 Go to the documentation of dart_repl 0.11.0 Download dart_repl 0.11.0 archive
0.10.0 Apr 19, 2017 Go to the documentation of dart_repl 0.10.0 Download dart_repl 0.10.0 archive
0.9.3 Jan 16, 2017 Go to the documentation of dart_repl 0.9.3 Download dart_repl 0.9.3 archive
0.9.2 Jan 16, 2017 Go to the documentation of dart_repl 0.9.2 Download dart_repl 0.9.2 archive
0.9.1 Jan 16, 2017 Go to the documentation of dart_repl 0.9.1 Download dart_repl 0.9.1 archive
0.9.0 Jan 15, 2017 Go to the documentation of dart_repl 0.9.0 Download dart_repl 0.9.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
3
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
1
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0