A proof of concept REPL environment for Dart.
See the Dart REPL Directions brain-dump for possible ideas and directions.
pub global run
You can install and setup
pub global activate dart_repl
To run it, simply execute:
pub global run dart_repl
If you run it from a directory that contains a Dart package (it needs a .packages file), it will load all dependencies automatically and allow you to import libraries adhoc:
pub global run dart_repl --adhoc-import package:built_collection/built_collection.dart
(if your package depends on built_collection).
This is the preferred way of running dart_repl as it requires no additional setup.
You can add a
dev_dependency: to your
dev_dependencies: dart_repl: [...]
You can then run the REPL with:
pub run dart_repl
It will automatically resolve all additional adhoc imports against the dependencies of your package:
pub run dart_repl --adhoc-import package:built_collection/built_collection.dart
From the command-line
To import additional libraries, you need to specify a package directory (--package-dir) to allow it to resolve dependencies:
dart bin/dart_repl.dart --package-dir ~/git/built_collection.dart/ --adhoc-import lib/built_collection.dart
Please file feature requests and bugs at the issue tracker.
Add this to your package's pubspec.yaml file:
dependencies: dart_repl: ^0.10.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.11.1||Apr 19, 2017|
|0.11.0||Apr 19, 2017|
|0.10.0||Apr 19, 2017|
|0.9.3||Jan 16, 2017|
|0.9.2||Jan 16, 2017|
|0.9.1||Jan 16, 2017|
|0.9.0||Jan 15, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.0.0 <2.0.0|