dart_repl_sandbox 0.11.1

  • README.md
  • Installing
  • Versions
  • 6

Sandbox virtual package

The code in sandbox/ is used in the sandbox isolate. It is set up as a package with no dependencies. Do not import anything outside of sandbox/ from this directory. You can only use relative import paths.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dart_repl_sandbox: ^0.11.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dart_repl_sandbox/cell.dart';
import 'package:dart_repl_sandbox/cell_environment.dart';
import 'package:dart_repl_sandbox/data_queue.dart';
import 'package:dart_repl_sandbox/isolate_messages.dart';
import 'package:dart_repl_sandbox/message_channel.dart';
import 'package:dart_repl_sandbox/message_converter.dart';
import 'package:dart_repl_sandbox/message_queue.dart';
import 'package:dart_repl_sandbox/scope.dart';
Version Uploaded Documentation Archive
0.11.1 Apr 19, 2017 Go to the documentation of dart_repl_sandbox 0.11.1 Download dart_repl_sandbox 0.11.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0