dart_rope 0.1.1

  • README.md
  • Installing
  • Versions
  • 0


An implementation of the Rope data structure in Dart.

This is a project for learning Dart (for fun) and also to learn how to implement a Rope.

Also it so happens that there's no existing implementation of a rope in Dart as far as I can tell, so maybe someone writing a text editor will find this useful (but probably not).

This is a work in progress. The hard parts (concatenation and split) are still unfinished.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dart_rope: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dart_rope/dart_rope.dart';
Version Uploaded Documentation Archive
0.1.1 Nov 1, 2017 Go to the documentation of dart_rope 0.1.1 Download dart_rope 0.1.1 archive
0.1.0 Nov 1, 2017 Go to the documentation of dart_rope 0.1.0 Download dart_rope 0.1.0 archive
0.0.1 Nov 1, 2017 Go to the documentation of dart_rope 0.0.1 Download dart_rope 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0