dart_rope 0.1.1

  • README.md
  • Installing
  • Versions
  • 45

dart_rope

An implementation of the Rope data structure in Dart.

This is a project for learning Dart (for fun) and also to learn how to implement a Rope.

Also it so happens that there's no existing implementation of a rope in Dart as far as I can tell, so maybe someone writing a text editor will find this useful (but probably not).

This is a work in progress. The hard parts (concatenation and split) are still unfinished.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_rope: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:dart_rope/dart_rope.dart';
  
Version Uploaded Documentation Archive
0.1.1 Nov 1, 2017 Go to the documentation of dart_rope 0.1.1 Download dart_rope 0.1.1 archive
0.1.0 Nov 1, 2017 Go to the documentation of dart_rope 0.1.0 Download dart_rope 0.1.0 archive
0.0.1 Nov 1, 2017 Go to the documentation of dart_rope 0.0.1 Download dart_rope 0.0.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
45
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:dart_rope/dart_rope.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dart_rope.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 4 hints.

    Run dartfmt to format lib/dart_rope.dart.

    Run dartfmt to format lib/src/rope.dart.

    Similar analysis of the following files failed:

    • lib/src/rope_node.dart (hint)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
Dev dependencies
test ^0.12.0