dart_ssh_two 0.0.3

  • README.md
  • Installing
  • Versions
  • 33


A SSH2 Client library for Dart Lang


This is currently a placeholder package! Please visit the homepage to get progress.

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Updates to readme and copyright


  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:

  dart_ssh_two: "^0.0.3"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dart_ssh_two/dart_ssh_two.dart';
Version Uploaded Documentation Archive
0.0.3 Aug 13, 2016 Go to the documentation of dart_ssh_two 0.0.3 Download dart_ssh_two 0.0.3 archive
0.0.2 Aug 13, 2016 Go to the documentation of dart_ssh_two 0.0.2 Download dart_ssh_two 0.0.2 archive
0.0.1 Aug 13, 2016 Go to the documentation of dart_ssh_two 0.0.1 Download dart_ssh_two 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
75 / 100
Reflects how tidy and up-to-date the package is. [more]
52 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:dart_ssh_two/dart_ssh_two.dart.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
Dev dependencies
test >=0.12.0 <0.13.0