A command line application to update the Dart SDK for Linux x64 systems.
pub global activate dart_updater
dart_updater, you must add 2 variables to your environment variables :
DART_SDK_PATH: Path where the Dart SDK will be installed.
You should also have a standalone Dart version somewhere on your system to run this package. But once you run it once, you can always keep your SDK up-to-date.
$ dart_updater --help
$ dart_updater upgrade --help
$ dart_updater upgrade -c dev/release
$ dart_updater upgrade -c stable/release
You can install the package from the command line:
$ pub global activate dart_updater
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: dart_updater: ^0.4.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.4.0||Nov 9, 2017|
|0.3.0||Oct 15, 2017|
|0.2.0||Apr 18, 2017|
|0.1.1||Mar 24, 2016|
|0.1.0||Sep 17, 2015|
|0.0.42||Sep 17, 2015|
|0.0.41||Jul 31, 2015|
|0.0.4||Jul 31, 2015|
|0.0.3||Jul 30, 2015|
|0.0.2||Jul 30, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Fix dependencies in
pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.1.0. Because dart_updater depends on unscripted >=0.0.2 which requires SDK version <2.0.0, version solving failed.
Fix platform conflicts. (-20 points)
Error(s) prevent platform classification:
Fix dependencies in
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
analysis_options.yaml. (-10 points)
Change the name of your package's
.analysis_options file to
Package is getting outdated. (-26.30 points)
The package was last published 65 weeks ago.
The package description is too short. (-12 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
dart_updater.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=1.11.1 <3.0.0|