dart_webcrypto 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

dart-webcrypto

This is a wrapper library to easily make the webcrypto capabilities available in Dart. Currently only hash functions available, where also a native Dart implementation is available.

If the selected browser does not support webcrypto API the library falls back to native Dart implementations.

Unfortunetaly the promise based webcrypto interface is not compatible with the synchronous native Hash interface.

var h = new SHA1();
h.add(UTF8.encode("hashme"));
h.close().then((List<int> digest){
    print(CryptoUtils.bytesToHex(digest));
});

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_webcrypto: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_webcrypto/dart_webcrypto.dart';
  
Version Uploaded Documentation Archive
0.0.3 May 15, 2017 Go to the documentation of dart_webcrypto 0.0.3 Download dart_webcrypto 0.0.3 archive
0.0.2 May 31, 2016 Go to the documentation of dart_webcrypto 0.0.2 Download dart_webcrypto 0.0.2 archive
0.0.1 Sep 8, 2015 Go to the documentation of dart_webcrypto 0.0.1 Download dart_webcrypto 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0