dartabase_core 1.0.0

  • README.md
  • Installing
  • Versions
  • 0

Dartabase Core

[visit http://dartabase-app.appspot.com](http://dartabase-app.appspot.com/)

shared lib used by Dartabase Tools (no need for you to do anything)

changelog 1.0.0
 changed Dart SDK to sdk: '>=2.0.0-dev.32.0 <2.0.0'
changelog 0.6.1
 added missing sqlite string on configLoad
changelog 0.6.0
 started adding sqlite support
changelog 0.5.2    
 fixed issue with default value for Date/Time
changelog 0.5.1
 improved console output 
 adapted database type recognition to enable BLOBs
changelog 0.5.0
 create backup of generated files if already exists and content changed
 added database types for creating dart files from extracting existing databases
 added variable relationDivider char_${relationDivider}_user eg char_2_user or char_t0_user
changelog 0.4.1 
 now using pretty print to store json in files
changelog 0.4.0 
 now working with _InternalLinkedHashMap instead of _LinkedHashMap

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartabase_core: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartabase_core/dartabase_core.dart';
  
Version Uploaded Documentation Archive
1.0.0 Mar 5, 2018 Go to the documentation of dartabase_core 1.0.0 Download dartabase_core 1.0.0 archive
0.6.2 Nov 5, 2016 Go to the documentation of dartabase_core 0.6.2 Download dartabase_core 0.6.2 archive
0.6.1 Oct 6, 2016 Go to the documentation of dartabase_core 0.6.1 Download dartabase_core 0.6.1 archive
0.6.0+1 Oct 3, 2016 Go to the documentation of dartabase_core 0.6.0+1 Download dartabase_core 0.6.0+1 archive
0.6.0 Sep 30, 2016 Go to the documentation of dartabase_core 0.6.0 Download dartabase_core 0.6.0 archive
0.5.2 Sep 21, 2016 Go to the documentation of dartabase_core 0.5.2 Download dartabase_core 0.5.2 archive
0.5.1 Aug 14, 2016 Go to the documentation of dartabase_core 0.5.1 Download dartabase_core 0.5.1 archive
0.5.0 Jul 4, 2016 Go to the documentation of dartabase_core 0.5.0 Download dartabase_core 0.5.0 archive
0.4.1 May 31, 2016 Go to the documentation of dartabase_core 0.4.1 Download dartabase_core 0.4.1 archive
0.4.0 May 22, 2016 Go to the documentation of dartabase_core 0.4.0 Download dartabase_core 0.4.0 archive

All 27 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.32.0 <2.0.0