dartcoin 0.0.0

  • README.md
  • Installing
  • Versions
  • 0

dartcoin-lib

Bitcoin library witten in Google Dart (dartlang.org).

This library is still in very early development so it is far from usable. Excpect many refactors to happen before we achieve a stable state.

All help is of course welcome!

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartcoin: ^0.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartcoin/dartcoin.dart';
  
Version Uploaded Documentation Archive
0.0.0 Jan 26, 2014 Go to the documentation of dartcoin 0.0.0 Download dartcoin 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Fix platform conflicts.

Error(s) prevent platform classification:

Make sure dartfmt runs.

Make sure dartfmt runs.

Running dartfmt -n . failed with the following output:

Exception: dartfmt on lib/ failed with exit code 65
Could not format because the source could not be parsed:

line 523, column 55 of lib/src/script/script_executor.dart: Expected to find ')'.
              executeCheckSig(txContainingThis, (int) index, script, stack, lastCodeSepLocation, opcode);
                                                      ^^^^^
line 523, column 55 of lib/src/script/script_executor.dart: Expected to find ';'.
              executeCheckSig(txContainingThis, (int) index, script, stack, lastCodeSepLocation, opcode);
                                                      ^
line 523, column 55 of lib/src/script/script_executor.dart: Expected to find ';'.

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because dartcoin depends on json_rpc any which requires SDK version <2.0.0, version solving failed.

Package is too old.

The package was released more than two years ago.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Homepage is not helpful.

Update the homepage property: create a website about the package or use the source repository URL.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dartcoin.dart.

Package is pre-v0.1 release.

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.