darteventkit 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Dart library darteventkit #

POC and working dart native (cocoa) binding for EventKit (macOS only).

Actual library will fetch events for a given calendar in the timeframe from today back to 2 years.

Xcode settings #

Link needed library

General Settings

Build Settings

Build Settings

Changelog #

0.0.3 (2016-11-27)

  • handles unknown calendar

0.0.2 (2016-11-26)

  • renamed 'screenshots' folder to 'doc' (pub convention)

0.0.1 (2016-11-26)

  • inital poc and working binding for events as json for a given calendar

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  darteventkit: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:darteventkit/darteventkit.dart';
  
Version Uploaded Documentation Archive
0.0.3 Nov 27, 2016 Go to the documentation of darteventkit 0.0.3 Download darteventkit 0.0.3 archive
0.0.2 Nov 26, 2016 Go to the documentation of darteventkit 0.0.2 Download darteventkit 0.0.2 archive
0.0.1 Nov 26, 2016 Go to the documentation of darteventkit 0.0.1 Download darteventkit 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.