darteventkit 0.0.3

  • README.md
  • Installing
  • Versions
  • 30

Dart library darteventkit

POC and working dart native (cocoa) binding for EventKit (macOS only).

Actual library will fetch events for a given calendar in the timeframe from today back to 2 years.

Xcode settings

Link needed library

General Settings

Build Settings

Build Settings


0.0.3 (2016-11-27)

  • handles unknown calendar

0.0.2 (2016-11-26)

  • renamed 'screenshots' folder to 'doc' (pub convention)

0.0.1 (2016-11-26)

  • inital poc and working binding for events as json for a given calendar

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  darteventkit: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:darteventkit/darteventkit.dart';
Version Uploaded Documentation Archive
0.0.3 Nov 27, 2016 Go to the documentation of darteventkit 0.0.3 Download darteventkit 0.0.3 archive
0.0.2 Nov 26, 2016 Go to the documentation of darteventkit 0.0.2 Download darteventkit 0.0.2 archive
0.0.1 Nov 26, 2016 Go to the documentation of darteventkit 0.0.1 Download darteventkit 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4


Detected platforms: other

Primary library: package:darteventkit/darteventkit.dart with components: nativewrappers.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is getting outdated. (-86.85 points)

The package was released 97 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use darteventkit.dart.