dartfix 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new44

dartfix

dartfix is a tool for migrating Dart source to newer versions of the Dart SDK, and fixing common issues including:

Usage

To activate the package

  pub global activate dartfix

Once activated, dart fix can be run using

  pub global run dartfix:fix <target directory>

or if you have setup your path to include the pub bin directory, then simply

  dartfix <target directory>

0.1.1

  • Remove reading dartfix version from pubspec

0.1.0

  • Initial version

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dartfix

2. Use it

The package has the following executables:


$ dartfix

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartfix: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartfix/handler/analysis_complete_handler.dart';
import 'package:dartfix/listener/bad_message_listener.dart';
import 'package:dartfix/listener/recording_listener.dart';
import 'package:dartfix/listener/timed_listener.dart';
  
Version Uploaded Documentation Archive
0.1.1 Nov 20, 2018 Go to the documentation of dartfix 0.1.1 Download dartfix 0.1.1 archive
0.1.0 Nov 20, 2018 Go to the documentation of dartfix 0.1.0 Download dartfix 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io.

Maintenance issues and suggestions

Support latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dartfix.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0-dev.9.2 <2.3.0
analysis_server_client 1.1.1 1.1.1
args ^1.4.0 1.5.1
cli_util ^0.1.3 0.1.3+2
path ^1.6.0 1.6.2
pub_semver ^1.4.2 1.4.2
Transitive dependencies
collection 1.14.11
Dev dependencies
analyzer ^0.33.0
test ^1.3.0