dartifact 0.6.86

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 35

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartifact: "^0.6.86"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartifact/dartifact.dart';
        
Version Uploaded Documentation Archive
0.6.86 Jul 22, 2017 Go to the documentation of dartifact 0.6.86 Download dartifact 0.6.86 archive
0.6.85 Jul 22, 2017 Go to the documentation of dartifact 0.6.85 Download dartifact 0.6.85 archive
0.6.84 Apr 24, 2017 Go to the documentation of dartifact 0.6.84 Download dartifact 0.6.84 archive
0.6.83 Apr 24, 2017 Go to the documentation of dartifact 0.6.83 Download dartifact 0.6.83 archive
0.6.81 Apr 24, 2017 Go to the documentation of dartifact 0.6.81 Download dartifact 0.6.81 archive
0.6.8 Apr 24, 2017 Go to the documentation of dartifact 0.6.8 Download dartifact 0.6.8 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
60 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85 / 100
Overall score:
Weighted score of the above. [more]
35

Platforms

Detected platforms: web

Primary library: package:dartifact/dartifact.dart with components: html, js, mirrors.

Suggestions

  • Fix lib/component.dart.

    Strong-mode analysis of lib/component.dart failed with the following error:

    line: 104 col: 31
    A value of type 'List<String>' can't be assigned to a variable of type 'String'.

  • Fix lib/components/numeric_form_field_component.dart.

    Strong-mode analysis of lib/components/numeric_form_field_component.dart failed with the following error:

    line: 34 col: 41
    Undefined name 'max_length'.

  • Fix further 11 Dart files.

    Similar analysis of the following files failed:

    • lib/components/button_component.dart
    • lib/components/radio_button_component.dart
    • lib/components/form_field_component.dart
    • lib/modules/position_manager.dart
    • lib/modules/auto_show_hide.dart
    • lib/modules/component_dom.dart
    • lib/modules/component_heritage.dart
    • lib/modules/i18n.dart
    • lib/modules/component_validation.dart
    • lib/behaviors/form_field_component_behaviors.dart
    • lib/behaviors/button_component_behaviors.dart
  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 3 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dartifact.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
animation >=0.5.24 <0.6.0 0.5.24
attributable >=0.1.1 <0.2.0 0.1.2
cookie >=0.0.4 <0.0.5 0.0.4
heritage_tree >=0.1.0 <0.2.0 0.1.0
logmaster >=0.1.1 <0.2.0 0.1.1
observable_roles >=0.1.43 <0.2.0 0.1.44
queries >=0.0.15 <0.5.0 0.0.15
validatable >=0.1.2 <0.2.0 0.1.2
Transitive dependencies
browser 0.10.0+2
Dev dependencies
mockito >=0.11.0
test >=0.12.0