dartivity_database 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 50

dartivity_database

This package provides the database component of the Dartivity suite of IOT monitoring and control packages.

The database component consists of both Dartivity entity definition classes and the database classes which use them. This allows the database classes to be specialised for any particular usage such as the resource database class which provides general database facilities for the Dartivity resource class.

Underlying the database classes are database driver classes that perform the function of interfacing with a specific database. Currently only one database driver is supported, for CouchDb. CouchDb gives an efficient, scalable NoSql database solution that supports full redundancy and replication facilities. This allows historic data such as events etc. to be handled seperately from current live data giving better access to such data.

This structure allows different database architectures to be used should future requirements call for this, for example Googles Cloud Datastore or even a traditional SQL database such as MariaDb.

The database component can be used anywhere in the Dartivity suite, by Dartivity clients for discovered resource handling and event handling and by the Dartivity Control front end web application for access to resource parameters, events etc.

Note that in this release only resource handling is supported, please refer to the individual class descriptions for more specific details and the test suite for usage examples.

1.0.0

1.0.0, Dart 2.0 updates

0.3.0

Add a bulk insert method to the cache

0.2.0

Issue 1 and cache class method additions

0.1.0

  • Initial version

example/example.dart

/*
 * Package : dartivity_database
 * Author : S. Hamblett <steve.hamblett@linux.com>
 * Date   : 04/09/2018
 * Copyright :  S.Hamblett 2018
 */

/// This package is a plugin/support package for the Dartivity IOT suite,
/// as such it has no specific standalone usage examples. See the test
/// suite for instantiation details.
int main() {
  return 0;
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartivity_database: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartivity_database/dartivity_database.dart';
  
Version Uploaded Documentation Archive
1.0.0 Sep 4, 2018 Go to the documentation of dartivity_database 1.0.0 Download dartivity_database 1.0.0 archive
0.3.0 Dec 2, 2015 Go to the documentation of dartivity_database 0.3.0 Download dartivity_database 0.3.0 archive
0.2.0 Dec 1, 2015 Go to the documentation of dartivity_database 0.2.0 Download dartivity_database 0.2.0 archive
0.1.0 Nov 26, 2015 Go to the documentation of dartivity_database 0.1.0 Download dartivity_database 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:dartivity_database/dartivity_database.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
crypto >=2.0.1 <3.0.0 2.0.6
json_object_lite ^2.0.0 2.0.0
wilt >=4.0.0 <=5.0.0 4.0.1
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
http 0.11.3+17 0.12.0
http_parser 3.1.3
meta 1.1.6
path 1.6.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
Dev dependencies
build_runner ^0.10.0
build_test ^0.10.2
build_web_compilers ^0.4.0
coverage ^0.12.2
dart_style ^1.1.3
dartdoc ^0.20.3
test ^1.3.0