dartmonit 0.0.6

  • README.md
  • Installing
  • Versions
  • 41

dartmonit

Monitor Dart scripts, and run them on startup. This is very early in the development stages, so expect some changes.

Running dartmonit as a daemon is currently only supported on Linux and Windows.

Installation

For Unix/Linux variants:

pub global activate dartmonit

On Windows, you need to clone this repository, and add bin/dartmonit.bat to your PATH. The reason for this is that having dartmonit saved on your filesystem allows the install command to install the included Windows service, written in C#, and compiled to an .exe.

git clone https://github.com/thosakwe/dartmonit.git
SET PATH="<dartmonit-root>\bin";%PATH%

See here for a look at how to set environment variables system-wide.

To add a script to /etc/init.d:

sudo dartmonit env "PATH=$PATH" install

Usage

dartmonit is essentially an HTTP server, which runs as a daemon and exposes a simple API.

Most of the CLI commands query a running API.

To manually start the server (not as a daemon):

dartmonit start
dartmonit start --port 2245

2245 is the default port.

Now, you can run it as a service:

sudo service dartmonit start
sudo /etc/init.d/dartmonit start

You may have better luck with the /etc/init.d variant, rather than service.

Commands

Usage: dartmonit <command> [arguments]

Global options:
-h, --help    Print this usage information.

Available commands:
  help        Display help information for dartmonit.
  install     Configures dartmonit to run at startup.
  kill        Halts the execution of a given command.
  remove      Removes a command from the list of processes to execute.
  run         Spawns a child process at the given absolute path.
  start       Starts the dartmonit HTTP server.
  status      Fetches the status of a given process.
  stop        Instructs an active dartmonit server to shut down.
  uninstall   Uninstalls the dartmonit daemon.

Run "dartmonit help <command>" for more information about a command.

API

TODO: API documentation

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dartmonit

2. Use it

The package has the following executables:


$ dartmonit
Version Uploaded Documentation Archive
0.0.6 Jul 22, 2017 Go to the documentation of dartmonit 0.0.6 Download dartmonit 0.0.6 archive
0.0.5 Jul 22, 2017 Go to the documentation of dartmonit 0.0.5 Download dartmonit 0.0.5 archive
0.0.4 Jul 22, 2017 Go to the documentation of dartmonit 0.0.4 Download dartmonit 0.0.4 archive
0.0.3 Jul 22, 2017 Go to the documentation of dartmonit 0.0.3 Download dartmonit 0.0.3 archive
0.0.2 Jul 21, 2017 Go to the documentation of dartmonit 0.0.2 Download dartmonit 0.0.2 archive
0.0.1 Jul 21, 2017 Go to the documentation of dartmonit 0.0.1 Download dartmonit 0.0.1 archive
0.0.0 Jul 21, 2017 Go to the documentation of dartmonit 0.0.0 Download dartmonit 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
53
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Aug 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because dartmonit depends on angel_diagnostics >=1.0.0-dev+1 which requires SDK version <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed.

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is getting outdated.

The package was released 56 weeks ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use dartmonit.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0