darty_lisp 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new48

Darty LISP #

A library for LISP developers looking for Darty expreinces.

Usage #

A simple usage example:

import 'package:darty_lisp/darty_lisp.dart';

main() {
  // Lexer to generate tokens for LISP programs
  Tokens lexer = new Tokens();
  lexer.program = '(add 2 3)';
  lexer.generate();

  lexer.prettyPrint();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.1.0 #

  • Initial version
  • Includes a LISP lexer

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  darty_lisp: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:darty_lisp/darty_lisp.dart';
  
Version Uploaded Documentation Archive
0.1.1 Mar 25, 2019 Go to the documentation of darty_lisp 0.1.1 Download darty_lisp 0.1.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
92
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Apr 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: web, other

Primary library: package:darty_lisp/darty_lisp.dart with components: mirrors.

Health suggestions

Fix lib/src/tokens.dart. (-0.50 points)

Analysis of lib/src/tokens.dart reported 1 hint:

line 140 col 9: Use isEmpty instead of length

Maintenance suggestions

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
args ^1.5.1 1.5.1
path ^1.4.1 1.6.2
Dev dependencies
pedantic ^1.0.0
test ^1.0.0