dasic 1.1.1

  • README.md
  • Installing
  • Versions
  • 0

Dasic - Dart BASIC interpreter

Dasic is a complete standalone interpreter for a dialect of the original BASIC language. It handles tokenizing, parsing, interpreting, output, variables, expressions, and flow control, like a full-scale compiler or interpreter, just in miniature. I tried to keep the code simple and readable while still being short and readable.

If you've ever wanted a gentle introduction to how a programming languages work under the hood, Dasic is a good place to start.

Sample

Result of dasic packages/dasic/scripts/mandel.das

                                                ----------
                                          ---------++*+++-------
                                      -------------+++*=*=++-------
                                  ---------------++*==@@@=+++---------
                               -------------++++++=*@@@@@@@+++---------
                            ------------+++++++++===@@@@@@==++++++++++---
                         ------------+++**@@@=*@@@@@@@@@@@@@@@@===*====---
                     -------------++++++==*@@@@@@@@@@@@@@@@@@@@@@@@@*+++---
               -----++++++++++++++++++=@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@+++----
        -----------++=====+=*=+++++++*@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@*+----
    --------------+++++=@@@@@@@@*@===@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@=++-----
  -------------++++++=@@@@@@@@@@@@@@*@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@*+------
 ------++++++++++=*@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@+++------
 --++++=+++=+++@=*@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@=++++------
 ---------+++++++=====@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@=++------
   --------------++++===@@@@@@@@@@@==@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@++-----
     -------------++++==@*==*@=@==+==@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@*=++----
           --------+++=+++++=++++++++=@*@@@@@@@@@@@@@@@@@@@@@@@@@@@@@==*+----
                  --------------++++++=@=@@@@@@@@@@@@@@@@@@@@@@@@@@*=+++----
                       ------------++++++=@@@@@@@@@@@@@@@@@@@@@@*@@@@=+----
                           -----------++=@*==+=@@@**@@@@@@*=*=@=++++==+---
                              ------------++++++++=@@@@@@@@++++++-------
                                 --------------+++*@*@@@*=@++----------
                                    --------------++++=@=+++---------
                                        -----------++==++++-------
                                             -------=+--------

Install

If you don't have Dart on your machine - Download and install it from here

Install Dasic

    pub global activate dasic

Update Dasic

    # activate dasic again
    pub global activate dasic

Uninstall Dasic

    pub global deactivate dasic   

Usage

Try


    dasic packages/dasic/scripts/hello.das
    dasic packages/dasic/scripts/hellos.das
    dasic packages/dasic/scripts/mandel.das

More Info

The real information about Dasic, including the language syntax and how the interpreter works is all in with the code, so go ahead and read through Dasi.

If you have any questions, feel free to get in touch. Cheers!

Features and bugs

Please file feature requests and bugs at the issue tracker.

Thanks

I want to thank "Bob Nystrom" for his base-work "JASIC"! You can read more from Bob and about "A Complete Interpreter in One Java File" here on his Blog.
Java-Version of Dasic is Jasic

License

Copyright 2015 Michael Mitterer (office@mikemitterer.at),
IT-Consulting and Development Limited, Austrian Branch

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing,
software distributed under the License is distributed on an
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND,
either express or implied. See the License for the specific language
governing permissions and limitations under the License.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dasic

2. Use it

The package has the following executables:


$ dasic

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dasic: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dasic/dasic.dart';
  
Version Uploaded Documentation Archive
1.1.1 Nov 16, 2016 Go to the documentation of dasic 1.1.1 Download dasic 1.1.1 archive
1.1.0 Dec 8, 2015 Go to the documentation of dasic 1.1.0 Download dasic 1.1.0 archive
1.0.0 Jun 17, 2015 Go to the documentation of dasic 1.0.0 Download dasic 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0