dataset 0.0.1

  • Example
  • Installing
  • Versions
  • 7


Dataset is a Dart library that makes managing the data behind client-side visualisations easy, including realtime data. It takes care of the loading, parsing, sorting, filtering and querying of datasets as well as the creation of derivative datasets.


import 'package:dataset/dataset.dart';

main() {
  var ds = new Dataset.fromRows([
    {'one': 1, 'two': 4, 'three': 7}

  var ds2 = new Dataset.url('/data/simple.json');

  print(ds is Dataset);
  print(ds2 is Dataset);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dataset: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dataset/dataset.dart';
Version Uploaded Documentation Archive
0.0.1 May 30, 2016 Go to the documentation of dataset 0.0.1 Download dataset 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:dataset/dataset.dart.

Issues and suggestions

Fix lib/src/importers/remote.dart.

Analysis of lib/src/importers/remote.dart failed with 68 errors, 1 warning, 2 hints, including:

line 26 col 5: Undefined name 'options'.

line 26 col 15: Undefined name 'options'.

line 26 col 26: The operands of the '||' operator must be assignable to 'bool'.

line 28 col 10: '_url' can't be used as a setter because it is final.

line 28 col 17: Undefined name 'options'.

Fix lib/src/importers/polling.dart.

Analysis of lib/src/importers/polling.dart failed with 42 errors, including:

line 3 col 7: Missing concrete implementation of getter 'Importer.extract'.

line 21 col 26: The operands of the '||' operator must be assignable to 'bool'.

line 22 col 10: The setter 'interval' isn't defined for the class 'Polling'.

line 22 col 41: The operands of the '||' operator must be assignable to 'bool'.

line 23 col 10: The setter '_def' isn't defined for the class 'Polling'.


Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see

Package is too old.

The package was released more than two years ago.

Fix additional 10 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/view.dart (3 errors)
  • lib/src/types.dart (3 errors, 1 hint)
  • lib/src/column.dart (1 error, 2 hints)
  • lib/src/parsers/csv.dart (1 error)
  • lib/src/parsers/strict.dart (1 error)
  • lib/src/sync.dart (1 error)
  • lib/src/builder.dart (Run dartfmt to format lib/src/builder.dart.)
  • lib/src/importers/google_spreadsheet.dart ()
  • lib/src/parsers/delimited.dart ()
  • lib/src/parsers/google_spreadsheet.dart ()

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
csv >=3.0.1 <4.0.0 3.3.0 4.0.0
intl >=0.12.7 <0.13.0 0.12.7+1 0.15.7
quiver >=0.21.4 <0.22.0 0.21.4 2.0.0+1
Transitive dependencies
analyzer 0.27.6 0.32.3
args 0.13.7 1.4.4
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
csslib 0.14.4 0.14.4+1
glob 1.1.7
html 0.13.3+2
isolate 0.2.3 2.0.2
logging 0.11.3+2
matcher 0.12.4
package_config 1.0.5
path 1.6.2
petitparser 1.7.6
plugin 0.2.0+3
source_span 1.4.1
stack_trace 1.9.3
string_scanner 1.0.3
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+10
yaml 2.1.15
Dev dependencies
benchmark_harness any
test any