date_utils 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 43

date_utils

Build Status

A Dart library to manipulate DateTimes. Useful for creating calendar functionality.

Example

See Packages:

Tzolkin Web Calendar

flutter_calendar

Usage

  1. Add the following to your pubspec.yaml:
dev_dependencies:
    date_utils: ^0.0.1
  1. Run pub install

  2. Import the package in your Dart code

import 'package:date_utils/date_utils.dart';
  1. Use the Utils class.
// example
var date = new DateTime(2017, 3);
var lastDay = Utils.lastDayOfMonth(date);
print(lastDay.day);
// => 31

Changelog

0.0.1

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  date_utils: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:date_utils/date_utils.dart';
  
Version Uploaded Documentation Archive
0.0.2 Mar 22, 2018 Go to the documentation of date_utils 0.0.2 Download date_utils 0.0.2 archive
0.0.1 Mar 20, 2018 Go to the documentation of date_utils 0.0.1 Download date_utils 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
86
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0