datetime_helper 0.0.2

  • Example
  • Installing
  • Versions
  • 44


some common method for datetime method

pub package




[0.0.2] - update readme

[0.0.1] - first version


import 'package:datetime_helper/datetime_helper.dart';

void main() {
  var dateTime = DateHelper.getStartTimeOfDay(;

  print(dateTime); //2018-09-14 00:00:00.000

      DateTime.parse("2018-01-01"), DateTime.parse("2018-01-02"))); // false

  print(DateHelper.isAm(DateTime(2018, 1, 1, 0, 20))); // true
  print(DateHelper.isAm(DateTime(2018, 1, 1, 13, 20))); // false

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  datetime_helper: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:datetime_helper/datetime_helper.dart';
Version Uploaded Documentation Archive
0.0.2 Sep 14, 2018 Go to the documentation of datetime_helper 0.0.2 Download datetime_helper 0.0.2 archive
0.0.1 Sep 14, 2018 Go to the documentation of datetime_helper 0.0.1 Download datetime_helper 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:datetime_helper/datetime_helper.dart.

Health issues and suggestions

Document public APIs. (-1 points)

9 out of 9 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
Dev dependencies
test ^1.3.2