db_executor 0.1.0+1

  • README.md
  • Installing
  • Versions
  • 0

Database query executor

A database query executor that controls the concurrency (number of concurrently running queries) and handles the acquiring and release of the connections (e.g. in case of processing failure).


TODO: write basic example



  • version upgrades

Breaking changes

  • renamed limit to concurrency

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  db_executor: ^0.1.0+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:db_executor/db_executor.dart';
Version Uploaded Documentation Archive
0.1.0+1 Sep 20, 2017 Go to the documentation of db_executor 0.1.0+1 Download db_executor 0.1.0+1 archive
0.1.0 Sep 19, 2017 Go to the documentation of db_executor 0.1.0 Download db_executor 0.1.0 archive
0.0.1 Jan 1, 2017 Go to the documentation of db_executor 0.0.1 Download db_executor 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0