db_executor 0.1.0+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 61

Database query executor

A database query executor that controls the concurrency (number of concurrently running queries) and handles the acquiring and release of the connections (e.g. in case of processing failure).

Usage

TODO: write basic example

Changelog

0.1.0

  • version upgrades

Breaking changes

  • renamed limit to concurrency

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  db_executor: "^0.1.0+1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:db_executor/db_executor.dart';
  
Version Uploaded Documentation Archive
0.1.0+1 Sep 20, 2017 Go to the documentation of db_executor 0.1.0+1 Download db_executor 0.1.0+1 archive
0.1.0 Sep 19, 2017 Go to the documentation of db_executor 0.1.0 Download db_executor 0.1.0 archive
0.0.1 Jan 1, 2017 Go to the documentation of db_executor 0.0.1 Download db_executor 0.0.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
53 / 100
Health:
Code health derived from static analysis. [more]
67 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
69 / 100
Overall score:
Weighted score of the above. [more]
61
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Error(s) in lib/postgresql.dart: Target of URI doesn't exist: 'package:postgresql/postgresql.dart'.

Suggestions

  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Error(s) in lib/postgresql.dart: Target of URI doesn't exist: 'package:postgresql/postgresql.dart'.

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 5 errors.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/postgresql.dart: Target of URI doesn't exist: 'package:postgresql/postgresql.dart'.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use db_executor.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
async >=1.0.0 <3.0.0 2.0.7
executor >=1.0.0 <1.1.0 1.0.1
Transitive dependencies
collection 1.14.10
dart2_constant 1.0.1+dart2
Dev dependencies
postgresql >=0.3.0 <0.4.0