ddp 0.0.5

  • README.md
  • Installing
  • Versions
  • new58


A new flutter package project.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  ddp: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:ddp/ddp.dart';
Version Uploaded Documentation Archive
0.0.5 Sep 17, 2018 Go to the documentation of ddp 0.0.5 Download ddp 0.0.5 archive
0.0.4 Sep 17, 2018 Go to the documentation of ddp 0.0.4 Download ddp 0.0.4 archive
0.0.3 Sep 17, 2018 Go to the documentation of ddp 0.0.3 Download ddp 0.0.3 archive
0.0.2 Sep 17, 2018 Go to the documentation of ddp 0.0.2 Download ddp 0.0.2 archive
0.0.1 Sep 4, 2018 Go to the documentation of ddp 0.0.1 Download ddp 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3


Detected platforms: Flutter, other

Primary library: package:ddp/ddp.dart with components: io.


The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use ddp.dart.

Package is pre-v0.1 release.

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Fix lib/ddp.dart.

Analysis of lib/ddp.dart reported 1 hint:

line 37 col 12: The value of the field '_timeout' isn't used.

Fix lib/ddp_client.dart.

Analysis of lib/ddp_client.dart reported 2 hints:

line 42 col 10: The value of the field '_serverId' isn't used.

line 45 col 10: The value of the field '_origin' isn't used.

Format lib/ddp_ejson.dart.

Run dartfmt to format lib/ddp_ejson.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <3.0.0
mutex ^1.0.1 1.0.1
sprintf ^4.0.0 4.0.0
tuple ^1.0.2 1.0.2
Transitive dependencies
matcher 0.12.4
meta 1.1.6
path 1.6.2
quiver 2.0.0+1
stack_trace 1.9.3
Dev dependencies
test ^1.3.0