debouncer 0.0.2

  • README.md
  • Installing
  • Versions
  • 0

Debouncer

Quick start:

import 'package:debouncer/debouncer.dart';

So, somewhere in your application:

Debouncer debouncer = new Debouncer(1000);
List<String> logs = [];

onChange(String val) {
  debouncer.run(logs.add, [val]);
}

So in this case logs.add will only be called with a single parameter that is val, when time between invocations is larger than 1000 milliseconds.

If the parameters change between calls to .run, only the last parameters which are passed are going to be used when the calls do not occur for given milliseconds.

If you call the same instance with different functions, only the last used function will be called when the calls do not occur for given milliseconds.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  debouncer: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:debouncer/debouncer.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jan 14, 2017 Go to the documentation of debouncer 0.0.2 Download debouncer 0.0.2 archive
0.0.1 Jan 14, 2017 Go to the documentation of debouncer 0.0.1 Download debouncer 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0