Just include it in your project, and you can overlay a debug grid with the
Shift - gto toggle between 6 and 12 columns.
lto display lines as well
Shift - lto toggle the visibility of columns only
Add this to your
dependencies: debug_grid: any
In your html, just include the grid like this:
<link rel="import" href="packages/debug_grid/debug_grid.html">
and put this at the end of your
That's it, you're good to go!
I'm assuming you have already a project setup with polymer! If not, please refer to the polymer dart documentation on how to do that, because this grid will not work otherwise.
Here is a fully configured debug grid:
<debug-grid totalWidth="1128" gutterWidth="24" lineHeight="24" columns="3" showColumns="false" showLines="true" visible="true" toggleKey="83" linesToggleKey="86"></debug-grid>
This would display a
1128px wide grid with
24px wide gutters,
height and 3 columns.
By default it is visible and would not show columns, but only lines (which can be toggled
with the appropriate keys).
The visibility toggle key has been remapped to
s) and the lines
toggle key has been remapped to
Add this to your package's pubspec.yaml file:
dependencies: debug_grid: ^0.4.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.4.0||May 22, 2016|
|0.3.0||Mar 31, 2016|
|0.2.3||Apr 1, 2015|
|0.2.2||Oct 21, 2014|
|0.2.1||Sep 5, 2014|
|0.2.0||Sep 2, 2014|
|0.1.1||Aug 26, 2014|
|0.1.0||Aug 22, 2014|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.9.0 <2.0.0|