deeplearnjs_facade 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

deeplearnjs_dart_facade

Dart wrapper for deelearnjs

Most code generated by js_facade_gen.

The deepleanjs library will remain unchanged from the generate code except for necessary modifications to make it strong-mode clean. See the manual changes for an overview of changes made.

A more darty interface will eventually be written that does away with the need for things like allowInterop for function arguments, replaces promises with futures and adheres to the dart style guide.

Usage

See examples for dart ports of the typescipt examples.

TODO

  1. Port more examples
  2. Write dart interface that encapsulates js interop requirements

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  deeplearnjs_facade: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:deeplearnjs_facade/deeplearnjs_facade.dart';
  
Version Uploaded Documentation Archive
0.0.1 Aug 20, 2017 Go to the documentation of deeplearnjs_facade 0.0.1 Download deeplearnjs_facade 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0