den 0.1.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

den pub package Build Status

A pubspec authoring tool.

##Install

pub global activate den

##Usage

# `den ...` requires Dart >=1.7, on 1.6 use `pub global run den ...`

# Create a pubspec.  Field value prompts default to your local git info.
den spec
# Bypass prompts, accept defaults.
den spec --force

# Bump your pubspec version (and do a tagged version commit if in a git repo)
den bump patch               # 1.2.3 -> 1.2.4
den bump minor               # 1.2.3 -> 1.3.0
den bump major --pre-id beta # 1.2.3 -> 2.0.0-beta.0
den bump release --pre       # 1.0.0-dev.2 -> 1.0.0-dev.3
den bump release             # 1.0.0-dev.2 -> 1.0.0
den bump build               # 1.0.2+1 -> 1.0.2+2
den bump breaking            # 0.5.1 -> 0.6.0 / 1.2.3 -> 2.0.0
den bump 1.2.3-dev           # 1.2.2 -> 1.2.3-dev
den bump minor -m "ver{v}"   # Custom commit message.

# Install dependencies (defaults to '>={latest stable} <{next breaking}')
den install polymer browser
den install unittest --dev
den install polymer#any
den install git://github.com/owner/repo.git -sgit
den install git://github.com/owner/repo#ref -sgit
den install path/to/foo -spath

# Uninstall dependencies
den uninstall junk kludge

# Keep dependencies up-to-date

# Show outdated (all by deafult)
den fetch
den fetch polymer

# Update outdated to '>={latest stable} <{next breaking}' (all by default)
den pull
den pull polymer

# Install comprehensive TAB-completion for den
den completion install

# Complete commands, options, package names, etc.
den i[TAB] -> install
den install unit[TAB] -> unittest
den uninstall j[TAB] -> junk
den fetch p[TAB] -> polymer
den pull p[TAB] -> polymer

###Package Authors

Add the following package installation instructions to your README:

pub global activate den
den install <your package name>

##^ Constraints

den install and den pull will take advantage of ^ constraints e.g. ^1.2.3 if either of:

  • Your sdk constraint disallows pre-1.8.0 SDKs when ^ was introduced.
  • You pass the --caret flag, which updates your sdk constraint for you.

Otherwise, they will use range syntax e.g. >=1.2.3 <2.0.0

##Programmatic Usage

The underlying functionality is available as a Dart API through the den_api package, which this package is merely a command-line interface for.

##Inspiration

den install was inspired by npm install --save and bower install --save den fetch and den pull were inspired by david and david update.

0.1.5 #

  • Added den spec command.

0.1.3 #

  • Added den bump command.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate den

2. Use it

The package has the following executables:


$ den
Version Uploaded Documentation Archive
0.1.6 Apr 20, 2015 Go to the documentation of den 0.1.6 Download den 0.1.6 archive
0.1.5 Feb 12, 2015 Go to the documentation of den 0.1.5 Download den 0.1.5 archive
0.1.4 Feb 11, 2015 Go to the documentation of den 0.1.4 Download den 0.1.4 archive
0.1.3 Jan 15, 2015 Go to the documentation of den 0.1.3 Download den 0.1.3 archive
0.1.2 Dec 10, 2014 Go to the documentation of den 0.1.2 Download den 0.1.2 archive
0.1.1 Oct 21, 2014 Go to the documentation of den 0.1.1 Download den 0.1.1 archive
0.1.0 Oct 21, 2014 Go to the documentation of den 0.1.0 Download den 0.1.0 archive
0.0.2 Oct 21, 2014 Go to the documentation of den 0.0.2 Download den 0.0.2 archive
0.0.1 Oct 20, 2014 Go to the documentation of den 0.0.1 Download den 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.6.0 <2.0.0