A tool to help you find missing, under-promoted, over-promoted, and unused dependencies.
Add the following to your pubspec.yaml:
dev_dependencies: dependency_validator: ^1.0.0
This package comes with a single executable: dependency_validator. To run this executable:
pub run dependency_validator. This usage will run the tool and report any missing, under-promoted, over-promoted, and unused dependencies.
lib/but only declared as a dev_dependency.
lib/but declared as a dependency.
dependency_validator --ignore coverage,dartdoc
--ignoreoption will no longer be reported at all (previously they were only being ignored in the "unused" list). #10 #12
You can install the package from the command line:
$ pub global activate dependency_validator
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: dependency_validator: "^1.1.2"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.1.2||Apr 9, 2018|
|1.1.1||Feb 28, 2018|
|1.1.0||Feb 27, 2018|
|1.0.1||Feb 9, 2018|
|1.0.0||Nov 17, 2017|
We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.24.2 <2.0.0|