dev_test 0.11.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 54

dev_test.dart

dev_test brings (back) the solo and skip features on top of the test package

Build Status

It is a layer on top of the test package that adds (back) the solo and skip feature so that you can run/debug a filtered set of tests from the IDE without having to use pub run test -n xxx. It remains however compatible the existing test package and tests can be run using pub run test. Make sure you have both dev_test and test as dependencies in your pubspec.yaml

solo_test, solo_group, skip_test, skip_group are marked as deprecated so that you don't commit code (check the dart analysis result) that might skip many needed tests. Also running tests will report if any tests were skipped.

Usage

Your pubspec.yaml should contain the following dev_depencencies:

dev_dependencies:
  test: any
  dev_test: any

In your xxxx_test.dart files replace

import 'package:test/test.dart';

with

import 'package:dev_test/test.dart';

solo_test, solo_group, skip_test, skip_group are marked as deprecated so that you don't commit code that might skip many needed tests.

testDescriptions add information about the current running test (list of String naming the current group and test)

devTestRun will be optionally needed if you have a mix of test and dev_test to make sure the declared tests or groups belongs to the correct group they are declared in

Testing

Testing with dartdevc

pub serve test --web-compiler=dartdevc --port=8079
pub run test -p chrome --pub-serve=8079

0.11.0

  • implicit-casts: false support

0.10.0

  • bug fix
  • dart 2.0.0 support

0.6.0

  • Add for multiple setUp(), tearDown(), setUpAll() and tearDownAll() in the same group
  • Travis test integration

0.5.0

  • Add support for setUpAll() and tearDownAll() methods

0.4.0

  • Initial revision with solo_test, solo_group, skip_test and skip_group support

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dev_test: "^0.11.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:dev_test/test.dart';
  
Version Uploaded Documentation Archive
0.11.0 Mar 2, 2018 Go to the documentation of dev_test 0.11.0 Download dev_test 0.11.0 archive
0.10.1 Dec 13, 2017 Go to the documentation of dev_test 0.10.1 Download dev_test 0.10.1 archive
0.10.0 Dec 10, 2017 Go to the documentation of dev_test 0.10.0 Download dev_test 0.10.0 archive
0.9.3 Jun 16, 2016 Go to the documentation of dev_test 0.9.3 Download dev_test 0.9.3 archive
0.9.1 Dec 17, 2015 Go to the documentation of dev_test 0.9.1 Download dev_test 0.9.1 archive
0.9.0 Dec 16, 2015 Go to the documentation of dev_test 0.9.0 Download dev_test 0.9.0 archive
0.8.0 Dec 14, 2015 Go to the documentation of dev_test 0.8.0 Download dev_test 0.8.0 archive
0.7.0 Oct 23, 2015 Go to the documentation of dev_test 0.7.0 Download dev_test 0.7.0 archive
0.6.1 Oct 13, 2015 Go to the documentation of dev_test 0.6.1 Download dev_test 0.6.1 archive
0.6.0 Oct 12, 2015 Go to the documentation of dev_test 0.6.0 Download dev_test 0.6.0 archive

All 15 versions...

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
10 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]
54
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

  • Use constrained dependencies.

    The pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies: collection, stack_trace, test.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use dev_test.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0
collection >=1.14.3 1.14.10
stack_trace any 1.9.2
test >=0.12.29 0.12.40
Transitive dependencies
analyzer 0.32.1
args 1.4.3
async 2.0.7
boolean_selector 1.0.3
charcode 1.1.1
convert 2.0.1
crypto 2.0.3
csslib 0.14.4
front_end 0.1.1
glob 1.1.5
html 0.13.3+1
http 0.11.3+16
http_multi_server 2.0.5
http_parser 3.1.2
io 0.3.2+1
js 0.6.1
kernel 0.3.1
logging 0.11.3+1
matcher 0.12.2+1
meta 1.1.5
mime 0.9.6+1
multi_server_socket 1.0.1
node_preamble 1.4.2
package_config 1.0.3
package_resolver 1.0.3
path 1.6.0
plugin 0.2.0+2
pool 1.3.5
pub_semver 1.4.1
shelf 0.7.3+1
shelf_packages_handler 1.0.3
shelf_static 0.2.7+1
shelf_web_socket 0.2.2+2
source_map_stack_trace 1.1.4
source_maps 0.10.5
source_span 1.4.0
stream_channel 1.6.7
string_scanner 1.0.2
term_glyph 1.0.0
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
web_socket_channel 1.0.8
yaml 2.1.14
Dev dependencies
browser any
fs_shim >=0.7.3
process_run >=0.5.6
tekartik_pub