dev_test brings (back) the solo and skip features on top of the
It is a layer on top of the
test package that adds (back) the solo and skip feature so that you can run/debug a filtered set of tests from the IDE without having to use
pub run test -n xxx.
It remains however compatible the existing
test package and tests can be run using
pub run test. Make sure you have both
test as dependencies in your pubspec.yaml
skip_group are marked as deprecated so that you don't commit code (check the dart analysis result) that
might skip many needed tests. Also running tests will report if any tests were skipped.
pubspec.yaml should contain the following dev_depencencies:
dev_dependencies: test: any dev_test: any
xxxx_test.dart files replace
skip_group are marked as deprecated so that you don't commit code that
might skip many needed tests.
testDescriptions add information about the current running test (list of String naming the current group and test)
devTestRun will be optionally needed if you have a mix of
dev_test to make sure the declared tests or groups belongs to the correct group they are declared in
pub serve test --web-compiler=dartdevc --port=8079 pub run test -p chrome --pub-serve=8079
tearDownAll()in the same group
Add this to your package's pubspec.yaml file:
dependencies: dev_test: "^0.10.1"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.10.1||Dec 13, 2017|
|0.10.0||Dec 10, 2017|
|0.9.3||Jun 16, 2016|
|0.9.1||Dec 17, 2015|
|0.9.0||Dec 16, 2015|
|0.8.0||Dec 14, 2015|
|0.7.0||Oct 23, 2015|
|0.6.1||Oct 13, 2015|
|0.6.0||Oct 12, 2015|
|0.4.5||Oct 6, 2015|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
No platform restriction found in libraries.
Use constrained dependencies.
pubspec.yamlcontains 2 dependencies without version constraints. Specify version ranges for the following dependencies:
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
None of the files in your
example/directory matches a known example patterns. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.24.0 <2.0.0|