diagonal 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 79

diagonal

Apply diagonal clipping to your widgets easily.

Example

import 'package:diagonal/diagonal.dart';
import 'package:flutter/material.dart';

class DiagonalExamples extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Diagonal Examples'),
      ),
      body: _getBody(),
    );
  }

  _getBody() {
    return ListView(
      children: <Widget>[
        Diagonal(
          child: Image.asset('assets/images/backdrop.jpg'),
          clipHeight: 90.0,
        ),
        Diagonal(
          child: Image.asset('assets/images/backdrop.jpg'),
          position: Position.BOTTOM_RIGHT,
          clipHeight: 90.0,
        ),
        Diagonal(
          child: Image.asset('assets/images/backdrop.jpg'),
          position: Position.TOP_LEFT,
          clipHeight: 90.0,
        ),
        Diagonal(
          child: Image.asset('assets/images/backdrop.jpg'),
          position: Position.TOP_RIGHT,
          clipHeight: 90.0,
        ),
      ]
          .map((item) => Padding(
                padding: EdgeInsets.only(bottom: 16.0),
                child: item,
              ))
          .toList(),
    );
  }
}

Credits

Photo by Jannis Brandt on Unsplash

[1.0.1] - 8/11/2018

  • Upgrade to Dart 2

[1.0.0] - 7/16/2018

  • Initial release 🎉
  • My first library ❤️
  • 4 positions to diagonally clip any widget with a given clipHeight.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:diagonal/diagonal.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Diagonal Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: DemoPage(),
    );
  }
}

class DemoPage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Diagonal Examples'),
      ),
      body: _getBody(),
    );
  }

  _getBody() => ListView(
        children: <Widget>[
          Diagonal(
            child: Image.asset('assets/images/backdrop.jpg'),
            clipHeight: 90.0,
          ),
          Diagonal(
            child: Image.asset('assets/images/backdrop.jpg'),
            position: Position.BOTTOM_RIGHT,
            clipHeight: 90.0,
          ),
          Diagonal(
            child: Image.asset('assets/images/backdrop.jpg'),
            position: Position.TOP_LEFT,
            clipHeight: 90.0,
          ),
          Diagonal(
            child: Image.asset('assets/images/backdrop.jpg'),
            position: Position.TOP_RIGHT,
            clipHeight: 90.0,
          ),
        ]
            .map((item) => Padding(
                  padding: EdgeInsets.only(bottom: 16.0),
                  child: item,
                ))
            .toList(),
      );
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  diagonal: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:diagonal/diagonal.dart';
  
Version Uploaded Documentation Archive
1.0.1 Aug 10, 2018 Go to the documentation of diagonal 1.0.1 Download diagonal 1.0.1 archive
1.0.0 Jul 16, 2018 Go to the documentation of diagonal 1.0.0 Download diagonal 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
65
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test