dialog_ahihi 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new66

dialog_ahihi

A new Flutter plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1

  • TODO: Describe initial release.

example/README.md

dialog_ahihi_example

Demonstrates how to use the dialog_ahihi plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dialog_ahihi: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dialog_ahihi/dialog_ahihi.dart';
  
Version Uploaded Documentation Archive
0.0.2 Nov 5, 2018 Go to the documentation of dialog_ahihi 0.0.2 Download dialog_ahihi 0.0.2 archive
0.0.1 Oct 30, 2018 Go to the documentation of dialog_ahihi 0.0.1 Download dialog_ahihi 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
94
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/dialog_ahihi.dart. (-6.42 points)

Analysis of lib/dialog_ahihi.dart reported 1 warning, 3 hints:

line 45 col 3: This function has a return type of 'Widget', but doesn't end with a return statement.

line 4 col 8: Unused import: 'package:flutter/services.dart'.

line 27 col 7: 'child' is deprecated and shouldn't be used.

line 45 col 10: Method doesn't override an inherited method.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8