dialogflow 0.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 85

Dialogflow package for Flutter apps. #

This package is modified from VictorRancesCode's package for compatible with Dart 2.

Installation #

  • Add this to your package's pubspec.yaml file:
dependencies:
  dialogflow: "^0.1.0"
  • You can install packages from the command line: with Flutter:
$ flutter packages get
  • Import it Now in your Dart code, you can use:
 import 'package:dialogflow/dialogflow.dart';

Usage #

  • Dialogflow register and create new Agent
  • Copy Api key (Token)
  • Code
  Dialogflow dialogflow = Dialogflow(token: "Your Token");
  AIResponse response = await dialogflow.sendQuery("Your Query");
  • Example
  void Response(query) async {
    Dialogflow dialogflow = Dialogflow(token: "Your token goes here");
    AIResponse response = await dialogflow.sendQuery(query);
    print(response.getMessageResponse());
  }

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.1.0] - TODO: 30-09-2018.

  • Updated environment sdk constraints to make the package Dart 2 compatible.

[0.0.1] - TODO: 27-05-2018.

  • This package help to integrate Dialogflow into Flutter apps. Initial commit by VictorRancesCode.

example/README.md

example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dialogflow: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dialogflow/dialogflow.dart';
  
Version Uploaded Documentation Archive
0.1.1 Nov 17, 2018 Go to the documentation of dialogflow 0.1.1 Download dialogflow 0.1.1 archive
0.1.0 Nov 4, 2018 Go to the documentation of dialogflow 0.1.0 Download dialogflow 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
92
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Feb 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

95 out of 95 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/dialogflow.dart. (-0.50 points)

Analysis of lib/dialogflow.dart reported 1 hint:

line 274 col 29: 'AUTHORIZATION' is deprecated and shouldn't be used.

Maintenance suggestions

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
flutter 0.0.0
http ^0.11.3+17 0.11.3+17 0.12.0+1
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
source_span 1.5.4
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test