discord 0.15.0

  • README.md
  • Installing
  • Versions
  • 9

Discord Dart

Build Status Our Discord Server Pub


A Dart library for Discord

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  discord: ^0.15.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:discord/discord.dart';
  
Version Uploaded Documentation Archive
0.15.0 Oct 23, 2016 Go to the documentation of discord 0.15.0 Download discord 0.15.0 archive
0.14.2 Oct 20, 2016 Go to the documentation of discord 0.14.2 Download discord 0.14.2 archive
0.14.1 Oct 19, 2016 Go to the documentation of discord 0.14.1 Download discord 0.14.1 archive
0.14.0 Oct 17, 2016 Go to the documentation of discord 0.14.0 Download discord 0.14.0 archive
0.13.3 Oct 15, 2016 Go to the documentation of discord 0.13.3 Download discord 0.13.3 archive
0.13.2 Oct 15, 2016 Go to the documentation of discord 0.13.2 Download discord 0.13.2 archive
0.13.1 Oct 15, 2016 Go to the documentation of discord 0.13.1 Download discord 0.13.1 archive
0.13.0 Oct 15, 2016 Go to the documentation of discord 0.13.0 Download discord 0.13.0 archive
0.12.0 Oct 10, 2016 Go to the documentation of discord 0.12.0 Download discord 0.12.0 archive
0.11.1 Oct 2, 2016 Go to the documentation of discord 0.11.1 Download discord 0.11.1 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
17
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
9
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because discord depends on intl >=0.2.8+2 <0.15.7 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/src/internal/_Http.dart.

Run dartfmt to format lib/src/internal/_Http.dart.

Format lib/src/objects/Shard.dart.

Run dartfmt to format lib/src/objects/Shard.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Homepage does not exists. (-20 points)

We were unable to access https://hackzzila.github.io/Discord-Dart/ at the time of the analysis.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is getting outdated. (-98.63 points)

The package was released 103 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use discord.dart.