dmi_read 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

DMI Read

A Dart library for reading .dmi spritesheet files used by the BYOND platform.

This library does not depend on dart:io, and thus can be used both in browser and the VM.

Current version has been tested against dmis generated by BYOND version 510.1347.

Background

BYOND is a proprietary game engine and platform, allowing creation of 2D tile-based multiplayer games through its Dream Maker component.

In BYOND game sources, sprites are kept in .dmi files. .dmi files are sprite sheets in a PNG file with a zTXt chunk containing metadata which describes the frames in the sprite sheet. An image viewer or editor will generally be able to open the whole sprite sheet, however, figuring out where the individual sprites are, and how they are grouped requires parsing the attached .dmi metadata.

Example

Print the names of every state in foo.dmi:

DmiSheet sheet = new DmiSheet.fromBytes(
    await new File('foo.dmi').readAsBytes());
sheet.states.forEach((state) {
  print(state.name);
});

For a slightly longer example, see dmi_read_example.dart.

Project

dmi_read is free software licensed under the ISC license. See the LICENSE file for details.

Bug reports and pull requests can be filed at github.com/DeeUnderscore/dmi_read.

Changelog

0.1.0

Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dmi_read: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dmi_read/dmi_read.dart';
  
Version Uploaded Documentation Archive
0.1.0 Dec 18, 2016 Go to the documentation of dmi_read 0.1.0 Download dmi_read 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0