dobx_ds 0.4.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 45

dobx lib for protostuffdb

Generate code (optional, generated code is checked in)

mkdir -p target
wget -O target/fbsgen-ds.jar https://repo1.maven.org/maven2/com/dyuproject/fbsgen/ds/fbsgen-ds-fatjar/1.0.1/fbsgen-ds-fatjar-1.0.1.jar
git clone https://gitlab.com/dyu/ds-proto.git p
./codegen.sh

Install deps

pub get

0.4.2

  • Add Store.page_info method

0.4.1

  • Fix append/prepend bug

0.4.0

  • Fix update/reload diff

0.3.0

  • Updated flutter (2017-04-04) and fixed broken imports caused by the update.

0.2.0

  • Added MultiCAS methods for update ops.
  • Added store with fetch and update with pubsub on loading/desc state.

0.1.0

  • json rpc over http

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dobx_ds: "^0.4.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dobx_ds/ds.dart';

import 'package:dobx_ds/mc.dart';

import 'package:dobx_ds/observables.dart';

import 'package:dobx_ds/observables.g.dart';

import 'package:dobx_ds/rpc.dart';

import 'package:dobx_ds/store.dart';

import 'package:dobx_ds/types.dart';

import 'package:dobx_ds/util.dart';

import 'package:dobx_ds/validation.dart';
        
Version Uploaded Documentation Archive
0.4.2 Aug 2, 2017 Go to the documentation of dobx_ds 0.4.2 Download dobx_ds 0.4.2 archive
0.4.1 Aug 2, 2017 Go to the documentation of dobx_ds 0.4.1 Download dobx_ds 0.4.1 archive
0.4.0 Apr 4, 2017 Go to the documentation of dobx_ds 0.4.0 Download dobx_ds 0.4.0 archive
0.3.0 Apr 4, 2017 Go to the documentation of dobx_ds 0.3.0 Download dobx_ds 0.3.0 archive
0.2.0 Mar 30, 2017 Go to the documentation of dobx_ds 0.2.0 Download dobx_ds 0.2.0 archive
0.1.0 Mar 22, 2017 Go to the documentation of dobx_ds 0.1.0 Download dobx_ds 0.1.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 10, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1
  • Flutter: 0.0.22

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]
45

Platforms

Detected platforms: unsure

Error(s) prevent platform classification.

Suggestions

  • Fix dependencies in pubspec.yaml.

    Running flutter packages pub upgrade failed with the following output:

    ERR: Invalid argument(s): Minimum version ("2.0.0-dev.23.0") must be less than maximum ("2.0.0-dev.16.0").
    ERR: package:pub_semver/src/version_range.dart 59         new VersionRange
     package:pub/src/pubspec.dart 366                     Pubspec._ensureEnvironment
     package:pub/src/pubspec.dart 331                     Pubspec.dartSdkConstraint
     package:pub/src/solver/backtracking_solver.dart 511  BacktrackingSolver._checkPubspecMatchesSdkConstraint
     package:pub/src/solver/backtracking_solver.dart 474  BacktrackingSolver._checkVersion
     ===== asynchronous gap ===========================
     package:pub/src/solver/backtracking_solver.dart 432  BacktrackingSolver._findValidVersion.<fn>
     ===== asynchronous gap ===========================
     dart:async                                           Future.doWhile
     package:pub/src/solver/backtracking_solver.dart 430  BacktrackingSolver._findValidVersion
     package:pub/src/solver/backtracking_solver.dart 337  BacktrackingSolver._versionQueueFor
     ===== asynchronous gap ===========================
     package:pub/src/solver/backtracking_solver.dart 290  BacktrackingSolver._solve.<fn>
     ===== asynchronous gap ===========================
     dart:async                                           _completeOnAsyncReturn
     package:pub/src/solver/backtracking_solver.dart 315  BacktrackingSolver._solve.<fn>
     dart:async                                           _completeOnAsyncReturn
     package:pub/src/solver/version_selection.dart 64     VersionSelection.select
     dart:async                                           _completeOnAsyncReturn
     package:pub/src/solver/version_selection.dart 91     VersionSelection._addDependencies
     dart:async                                           _completeOnAsyncReturn
     package:pub/src/solver/version_selection.dart 91     VersionSelection._addDependencies
    ERR: This is an unexpected error. Please run
     
         pub --trace upgrade --verbosity io --no-precompile
     
     and include the logs in an issue on https://github.com/dart-lang/pub/issues/new
    
  • Fix platform conflicts.

    Make sure none of the libraries use mutually exclusive dependendencies.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dobx_ds.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0