doc_coverage 0.1.5

  • Installing
  • Versions
  • 0

Dart doc coverage

The Dart doc coverage tool examines a Dart library (or package), judging the comments of the public API. Dart doc coverage examines exactly the comments that will appear at (e.g. path's docs)

  • 0% means that a library or class has 0 comments on any methods, variables, etc.
  • 100% means that a library or class has a comment for every method, variable, etc., and that each comment is formatted properly, according to some opinions.

Currently, Dart doc coverage examines the comments of:

  • libraries
  • classes
  • typedefs
  • errors
  • library-level functions
  • library-level variables
  • class-level methods (constructors, getters, setters, methods, operators)
  • class-level variables

In general, the formatting of comments is expected to follow the Guidelines for Dart Doc Comments. Specifically, the Dart doc coverage tool checks the following rules:


  • The following should have a comment: classes, methods, getters, setters, operators, constructors, and variables.
  • The first paragraph of any comment should be a one-sentence description.
  • A method comment should have at least two paragraphs. A variable comment can have just one.
  • A comment should end with a period.


Apache v2


Contributions welcome! Please read the contribution guidelines.


This is not an official Google product.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  doc_coverage: ^0.1.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:doc_coverage/doc_coverage_cli.dart';
import 'package:doc_coverage/doc_coverage_common.dart';
import 'package:doc_coverage/doc_coverage_frontend.dart';
Version Uploaded Documentation Archive
0.1.5 May 6, 2015 Go to the documentation of doc_coverage 0.1.5 Download doc_coverage 0.1.5 archive
0.1.4 Apr 20, 2015 Go to the documentation of doc_coverage 0.1.4 Download doc_coverage 0.1.4 archive
0.1.3 Apr 19, 2015 Go to the documentation of doc_coverage 0.1.3 Download doc_coverage 0.1.3 archive
0.1.2 Apr 14, 2015 Go to the documentation of doc_coverage 0.1.2 Download doc_coverage 0.1.2 archive
0.1.1 Apr 3, 2015 Go to the documentation of doc_coverage 0.1.1 Download doc_coverage 0.1.1 archive
0.1.0 Apr 3, 2015 Go to the documentation of doc_coverage 0.1.0 Download doc_coverage 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because doc_coverage depends on route >=0.0.2 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format bin/doc_coverage.dart.

Run dartfmt to format bin/doc_coverage.dart.

Format lib/src/cli/directory_writer_provider.dart.

Run dartfmt to format lib/src/cli/directory_writer_provider.dart.

Format lib/src/common/dartdoc_viewer_utils.dart.

Run dartfmt to format lib/src/common/dartdoc_viewer_utils.dart.

Fix additional 8 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/common/doc_coverage.dart (Run dartfmt to format lib/src/common/doc_coverage.dart.)
  • lib/src/common/markdown_writer.dart (Run dartfmt to format lib/src/common/markdown_writer.dart.)
  • lib/src/common/readable_string_sink.dart (Run dartfmt to format lib/src/common/readable_string_sink.dart.)
  • lib/src/common/utils.dart (Run dartfmt to format lib/src/common/utils.dart.)
  • lib/src/frontend/class_doc_analyzer.dart (Run dartfmt to format lib/src/frontend/class_doc_analyzer.dart.)
  • lib/src/frontend/error_handlers.dart (Run dartfmt to format lib/src/frontend/error_handlers.dart.)
  • lib/src/frontend/library_doc_analyzer.dart (Run dartfmt to format lib/src/frontend/library_doc_analyzer.dart.)
  • lib/src/frontend/member_doc_analyzer.dart (Run dartfmt to format lib/src/frontend/member_doc_analyzer.dart.)

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use doc_coverage.dart.