The Dart doc coverage tool examines a Dart library (or package), judging the comments of the public API. Dart doc coverage examines exactly the comments that will appear at dartdocs.org (e.g. path's docs)
Currently, Dart doc coverage examines the comments of:
In general, the formatting of comments is expected to follow the Guidelines for Dart Doc Comments. Specifically, the Dart doc coverage tool checks the following rules:
Contributions welcome! Please read the contribution guidelines.
This is not an official Google product.
Add this to your package's pubspec.yaml file:
dependencies: doc_coverage: ^0.1.5
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:doc_coverage/doc_coverage_cli.dart'; import 'package:doc_coverage/doc_coverage_common.dart'; import 'package:doc_coverage/doc_coverage_frontend.dart';
|0.1.5||May 6, 2015|
|0.1.4||Apr 20, 2015|
|0.1.3||Apr 19, 2015|
|0.1.2||Apr 14, 2015|
|0.1.1||Apr 3, 2015|
|0.1.0||Apr 3, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.