dockerfile 0.0.3

  • Example
  • Installing
  • Versions
  • --


A library for manipulating Dockerfile


A simple usage example:

import 'package:dockerfile/dockerfile.dart';

main() {
  var dockerfile = new Dockerfile();

  dockerfile.from('google/dart', tag: dartVersion);'pub', args: ['build']);
  dockerfile.add(somePath, otherPath);

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Fix analyzer warnings


  • tidy dependency versions


  • Initial version, created by Stagehand


// Copyright (c) 2015, Anders Holmgren. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library dockerfile.example;

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dockerfile: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dockerfile/dockerfile.dart';
Version Uploaded Documentation Archive
0.0.4 Mar 25, 2016 Go to the documentation of dockerfile 0.0.4 Download dockerfile 0.0.4 archive
0.0.3 Jan 23, 2016 Go to the documentation of dockerfile 0.0.3 Download dockerfile 0.0.3 archive
0.0.2 Jan 21, 2016 Go to the documentation of dockerfile 0.0.2 Download dockerfile 0.0.2 archive
0.0.1+2 Apr 19, 2015 Go to the documentation of dockerfile 0.0.1+2 Download dockerfile 0.0.1+2 archive
0.0.1+1 Apr 19, 2015 Go to the documentation of dockerfile 0.0.1+1 Download dockerfile 0.0.1+1 archive
0.0.1 Apr 19, 2015 Go to the documentation of dockerfile 0.0.1 Download dockerfile 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0