docs_analyzer 0.2.0

  • Installing
  • Versions
  • 32

Docs Analyzer

Analyze your Dart project for public elements missing documentation.

Getting started:

git clone
cd docs_analyzer
pub get
pub run docs_analyzer <project_path>


docs_analyzer <project_path>     Run docs_analyzer on the project located at <project_path>
docs_analyzer                    Run docs_analyzer on the current directory
docs_analyzer --help             Show this screen

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  docs_analyzer: "^0.2.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:docs_analyzer/docs_analyzer.dart';
Version Uploaded Documentation Archive
0.2.0 Aug 11, 2016 Go to the documentation of docs_analyzer 0.2.0 Download docs_analyzer 0.2.0 archive
0.1.0 Jul 7, 2016 Go to the documentation of docs_analyzer 0.1.0 Download docs_analyzer 0.1.0 archive


We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
98 / 100
Reflects how tidy and up-to-date the package is. [more]
11 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:docs_analyzer/docs_analyzer.dart with components: io.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Homepage does not exists.

    We were unable to access at the time of the analysis.

  • Package is getting outdated.

    The package was released 95 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use docs_analyzer.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 3 hints.

    Run dartfmt to format lib/docs_analyzer.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.1 <2.0.0
dartdoc ^0.8.3 0.8.5 0.20.0
Transitive dependencies
analyzer 0.27.6 0.32.1
args 0.13.7 1.4.3
async 2.0.7
charcode 1.1.1
cli_util 0.0.1+2 0.1.3
collection 1.14.10
convert 2.0.1
crypto 2.0.3
csslib 0.13.7+1 0.14.4
glob 1.1.5
html 0.12.2+2 0.13.3+1
http 0.11.3+16
http_parser 3.1.2
isolate 0.2.3 2.0.1
logging 0.11.3+1
markdown 0.8.0 2.0.0
matcher 0.12.2+1
mustache4dart 1.1.0 2.1.2
package_config 1.0.3
path 1.6.0
plugin 0.2.0+2
pub_cache 0.1.1 0.2.0
pub_semver 1.4.1
quiver 0.21.4 0.29.0+1
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
when 0.2.0
which 0.1.3
yaml 2.1.14
Dev dependencies
dart_dev ^1.1.1
dart_style 0.2.0