docs_analyzer 0.2.0

  • README.md
  • Installing
  • Versions
  • 0

Docs Analyzer

Analyze your Dart project for public elements missing documentation.

Getting started:

git clone https://github.com/adamhammes-wf/docs_analyzer.git
cd docs_analyzer
pub get
pub run docs_analyzer <project_path>

Usage:

docs_analyzer <project_path>     Run docs_analyzer on the project located at <project_path>
docs_analyzer                    Run docs_analyzer on the current directory
docs_analyzer --help             Show this screen

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  docs_analyzer: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:docs_analyzer/docs_analyzer.dart';
  
Version Uploaded Documentation Archive
0.2.0 Aug 11, 2016 Go to the documentation of docs_analyzer 0.2.0 Download docs_analyzer 0.2.0 archive
0.1.0 Jul 7, 2016 Go to the documentation of docs_analyzer 0.1.0 Download docs_analyzer 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.1 <2.0.0