document_chooser 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 85

document chooser plugin for flutter

A Flutter chooser to allow users to pick documenet files avaialble on their device. iOS implentation is based off this plugin;

Note: only chooseDocument is working chooseDocuments is currently broken on both platforms

Installation

First add document_chooser as a dependency in your pubspec.yaml file.

Permsionss

No configuration required - the plugin should work out of the box.

Example

import 'package:flutter/material.dart';
import 'package:document_chooser/document_chooser.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {

  List<String> _documents = [];

  @override
  void initState() {
    super.initState();
  }


  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: new Column(
          children: [
            getButton("Pick document", ()=>pickDocument()),
            getButton("Pick documents", ()=>pickDocuments()),
            Expanded(
              child: ListView(children: getDocuments(),),
            )
          ],
        ),
      ),
    );
  }

  Widget getButton(String text, Function action){
    return RaisedButton(
      onPressed: action,
      child: Text(text),
    );
  }

  pickDocument() async {
    String path = await DocumentChooser.chooseDocument();
    setState(()=>_documents = [path]);
  }

  pickDocuments() async {
    List<String> paths = await DocumentChooser.chooseDocuments();
    setState(()=>_documents = paths);
  }

  getDocuments() {
    return List.generate(_documents.length, (i) => Text(_documents[i]));
  }

}

0.0.1

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:document_chooser/document_chooser.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {

  List<String> _documents = [];

  @override
  void initState() {
    super.initState();
  }


  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: new Column(
          children: [
            getButton("Pick document", ()=>pickDocument()),
            getButton("Pick documents", ()=>pickDocuments()),
            Expanded(
              child: ListView(children: getDocuments(),),
            )
          ],
        ),
      ),
    );
  }

  Widget getButton(String text, Function action){
    return RaisedButton(
      onPressed: action,
      child: Text(text),
    );
  }

  pickDocument() async {
    String path = await DocumentChooser.chooseDocument();
    setState(()=>_documents = [path]);
  }

  pickDocuments() async {
    List<String> paths = await DocumentChooser.chooseDocuments();
    setState(()=>_documents = paths);
  }

  getDocuments() {
    return List.generate(_documents.length, (i) => Text(_documents[i]));
  }

}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  document_chooser: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:document_chooser/document_chooser.dart';
  
Version Uploaded Documentation Archive
0.0.2 Aug 17, 2018 Go to the documentation of document_chooser 0.0.2 Download document_chooser 0.0.2 archive
0.0.1 Aug 17, 2018 Go to the documentation of document_chooser 0.0.1 Download document_chooser 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Oct 26, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0-dev.7.1.flutter-b99bcfd309
  • pana: 0.12.5
  • Flutter: 0.10.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/document_chooser.dart.

Run flutter format to format lib/document_chooser.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8