dogma_rest_connection 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

dogma-rest-connection

A RESTful data connection for Dart

Changelog

0.0.1

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dogma_rest_connection: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dogma_rest_connection/rest_connection.dart';
  
Version Uploaded Documentation Archive
0.0.2 Feb 27, 2017 Go to the documentation of dogma_rest_connection 0.0.2 Download dogma_rest_connection 0.0.2 archive
0.0.1 Oct 26, 2015 Go to the documentation of dogma_rest_connection 0.0.1 Download dogma_rest_connection 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0