Development tools installer from command line.
> pub global activate dools
To update, run activate again.
You can install the package from the command line:
$ pub global activate dools
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: dools: "^0.0.10"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:dools/commands/builder.dart'; import 'package:dools/commands/install.dart'; import 'package:dools/commands/tools/gradle.dart'; import 'package:dools/commands/tools/maven.dart'; import 'package:dools/commands/tools/nodejs.dart'; import 'package:dools/error.dart'; import 'package:dools/text.dart';
|0.0.10||Jun 10, 2018|
|0.0.9||Jun 4, 2018|
|0.0.8||Jun 1, 2018|
|0.0.7||Jun 1, 2018|
|0.0.6||Apr 15, 2018|
|0.0.5||Apr 14, 2018|
|0.0.4||Apr 14, 2018|
We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Platform components identified in package:
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Fix analysis and formatting issues.
Analysis or formatting checks reported 11 hints.
Similar analysis of the following files failed:
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.20.1 <2.0.0|