drag_drop 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

travis build

Drag Drop library for Dart-driven apps

Designed to utilize HTML5 Drag and Drop API, it supports all major and modern browsers.

Due to nature of the underlying API, it's possible to implement system-wide drag'n'drop interactions.

It also provides ability to manage scroll-on-drag process.

Changelog

1.0.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  drag_drop: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:drag_drop/drag_drop.dart';
  
Version Uploaded Documentation Archive
1.0.0 Dec 4, 2017 Go to the documentation of drag_drop 1.0.0 Download drag_drop 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.1 <2.0.0