drag_drop_angular 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 66

travis build

Drag Drop library for Dart Angular-driven apps

Designed to utilize HTML5 Drag and Drop API, it supports all major and modern browsers.

Due to nature of the underlying API, it's possible to implement system-wide drag'n'drop interactions.

It also provides ability to manage scroll-on-drag process.

Based on drag_drop package GitHub, Pub

Usage

While reference is on the way, you can start exploring Live Examples or just run

pub serve web

Changelog

1.0.2

  • Live examples

1.0.1

  • Added missing index.html to run demo-app

1.0.0

  • Initial version

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  drag_drop_angular: "^1.0.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:drag_drop_angular/drag_drop.dart';

import 'package:drag_drop_angular/movement.dart';

import 'package:drag_drop_angular/scroll.dart';
        
Version Uploaded Documentation Archive
1.0.2 Dec 5, 2017 Go to the documentation of drag_drop_angular 1.0.2 Download drag_drop_angular 1.0.2 archive
1.0.1 Dec 5, 2017 Go to the documentation of drag_drop_angular 1.0.1 Download drag_drop_angular 1.0.1 archive
1.0.0 Dec 5, 2017 Go to the documentation of drag_drop_angular 1.0.0 Download drag_drop_angular 1.0.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
34 / 100
Health:
Code health derived from static analysis. [more]
97 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
66
Learn more about scoring.

Platforms

Detected platforms: web

Platform components identified in package: html.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 8 hints.

    Run dartfmt to format lib/src/drag_drop/base_drag_drop_directive.dart.

    Run dartfmt to format lib/src/drag_drop/directives.dart.

    Similar analysis of the following files failed:

    • lib/src/drag_drop/drag_directive.dart (hint)
    • lib/src/drag_drop/drop_directive.dart (hint)
    • lib/src/drag_drop/model_directive.dart (hint)
    • lib/src/drag_drop/providers.dart (hint)
    • lib/src/movement/providers.dart (hint)
    • lib/src/scroll/providers.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use drag_drop_angular.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.1 <2.0.0
angular2 >2.0.0 <=3.1.0 3.1.0 3.1.0+1
built_collection ^1.5.0 1.6.2 3.1.1
built_value ^2.1.0 2.1.0 5.4.3
drag_drop ^1.0.0 1.0.0
js ^0.6.1 0.6.1
logging ^0.11.3+1 0.11.3+1
throttle_debounce ^0.1.2 0.1.2+1
user_environment_angular ^1.0.0 1.0.0
Transitive dependencies
args 0.13.7 1.4.2
async 2.0.6
barback 0.15.2+15
browser_detect 1.0.4
build 0.9.3 0.12.2
build_barback 0.2.2 0.5.0+3
charcode 1.1.1
cli_util 0.1.2+1
code_builder 1.0.4 3.0.3
code_transformers 0.5.1+4
collection 1.14.9
convert 2.0.1
crypto 2.0.2+1
csslib 0.13.7+1 0.14.1
fixnum 0.10.7
front_end 0.1.0-alpha.4.1 0.1.0-alpha.11
func 1.0.0
glob 1.1.5
html 0.13.3
intl 0.15.6
isolate 1.1.0 2.0.0
kernel 0.3.0-alpha.1.1 0.3.0-alpha.11
matcher 0.12.2
meta 1.1.2
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
pool 1.3.4
protobuf 0.5.5 0.7.2
quiver 0.23.0 0.29.0+1
source_gen 0.5.10+1 0.8.1
source_maps 0.10.4
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
user_environment 1.0.1
utf 0.9.0+4
watcher 0.9.7+7
yaml 2.1.13
Dev dependencies
analyzer ^0.29.0 0.30.0+4 0.31.1
browser ^0.10.0
dart_dev any
dart_style any 1.0.9+1 1.0.10
less_dart any
test ^0.12.24+1