dribbble_client 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 8

dribbble_client

Build Status codecov

A library for interacting with the Dribbble Api.

Usage

  1. Register a new app with Dribble
  2. Obtain your access_token
  3. Install the dribbble_client: dependency in your project's pubspec.yaml
  4. Create a new DribbbleClient: final client = new DribbbleClient("YOUR_ACCESS_TOKEN");
  5. Profit: final shots = client.fetchPopularShots(pageSize: 50)

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.1.0

  • Rename collection List to to items for less confusion.
  • Expose fetchShots and fetchUsers as public methods for pagination purposes

0.0.2

  • Move to github

0.0.1

  • Has the ability to fetch the following from the Dribbble Api. None of these calls require authentication. Authenticated requests will be supported in the near future.

    • Individual Shot
    • Individual User
    • Popular Shots
    • Recent Shots
    • Animated Shots
    • Debut Shots
    • Team Members
    • Team Shots
    • Individual User
    • User Shots

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dribbble_client: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dribbble_client/dribbble_client.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jan 12, 2018 Go to the documentation of dribbble_client 0.1.0 Download dribbble_client 0.1.0 archive
0.0.2 Nov 26, 2017 Go to the documentation of dribbble_client 0.0.2 Download dribbble_client 0.0.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
8
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0