dropdown 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 67

statusbar

Flutter plugin use to show dropdown style alert messages.

How to Use

Dropdown.show("Hello world!", Colors.green, Colors.black);

1.0.1

  • Android dropdown now animates when shown
  • No longer showing empty messages

1.0.0

  • Display dropdown alert messages

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:dropdown/dropdown.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
    Dropdown.show("Hello world!", Colors.green, Colors.black);
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: Text(""),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dropdown: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dropdown/dropdown.dart';
  
Version Uploaded Documentation Archive
1.0.1 Sep 18, 2018 Go to the documentation of dropdown 1.0.1 Download dropdown 1.0.1 archive
1.0.0 Sep 17, 2018 Go to the documentation of dropdown 1.0.0 Download dropdown 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/dropdown.dart. (-0.50 points)

Analysis of lib/dropdown.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:async'.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8