dsbroker 1.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new0

Dart DSA Broker Slack

Getting Started

Prerequisites

Install

# Globally install the Dart DSA Broker
pub global activate -s git https://github.com/IOT-DSA/broker-dart.git

Start a Broker

# If you have the pub global executable path setup.
dsbroker

OR

# If you do not have the pub global executable path setup.
pub global run broker_dart:broker

You can edit the server configuration using broker.json. For more information about broker configuration, see Configuring a Broker.

Changelog

  • v1.1.0 - Start of changelog. Too many previous changes to list.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dsbroker

2. Use it

The package has the following executables:


$ dsbroker

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dsbroker: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dsbroker/broker.dart';
  
Version Uploaded Documentation Archive
1.1.0 Oct 31, 2018 Go to the documentation of dsbroker 1.1.0 Download dsbroker 1.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0