dto_validator 1.0.0

  • README.md
  • Installing
  • Versions
  • 46


A library for Dart backend developers.

Created from templates made available by Stagehand under a BSD-style license.


A simple usage example:

import 'package:validator/validator.dart';

class User {
  @Rules(min: 5)
  String email;

  @Rules(required: true, min: 5)
  int id;

  @Rules(required: true)
  String phone;

void main() async {
  var validator = new Validator();
  var user = new User()
  ..email = 'email@gmail.com'
    ..id = 2
    ..phone = '123123';
    var errors = await validator.validate(user);
    // {User.id: Cannot be less than 5}

For more examples see -



Run in console(from root directory)

pub run test .



  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dto_validator: "^1.0.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:dto_validator/dto_validator.dart';
Version Uploaded Documentation Archive
1.0.0 Mar 11, 2018 Go to the documentation of dto_validator 1.0.0 Download dto_validator 1.0.0 archive


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
89 / 100
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web, other

Primary library: package:dto_validator/dto_validator.dart with components: mirrors.


  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 errors 1 hint.

    Strong-mode analysis of lib/src/strategy.dart failed with the following error:

    line: 15 col: 3
    'validate' must have a method body because 'Strategy' isn't abstract.

    Run dartfmt to format lib/src/rules_exception.dart.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use dto_validator.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
Dev dependencies
test ^0.12.0