dto_validator 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

dto_validator

A library for Dart backend developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage

A simple usage example:

import 'package:validator/validator.dart';

class User {
  @Rules(min: 5)
  String email;

  @Rules(required: true, min: 5)
  int id;

  @Rules(required: true)
  String phone;
}

void main() async {
  var validator = new Validator();
  var user = new User()
  ..email = 'email@gmail.com'
    ..id = 2
    ..phone = '123123';
    
    var errors = await validator.validate(user);
    // {User.id: Cannot be less than 5}
    print(errors);
}

For more examples see -

/examples

Tests

Run in console(from root directory)

pub run test .

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dto_validator: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dto_validator/dto_validator.dart';
  
Version Uploaded Documentation Archive
1.0.0 Mar 11, 2018 Go to the documentation of dto_validator 1.0.0 Download dto_validator 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0