Dart Version Manager: Manage multiple active Dart versions.
WORK IN PROGRESS: See "progress" below, not yet a stable package!
$ pub global activate dvm
$ dvm Manage multiple active Dart versions. Usage: dvm <command> [arguments] Global options: -h, --help Print this usage information. -v, --version Print out the latest released version of dvm. -p, --path Installation directory for the Dart SDK. (defaults to "/Users/matanl/.dvm") Available commands: help Display help information for dvm. install Download and install a <version/channel>. switch Switches the `current` directory to <version/channel>.
This package is a work in progress, and pull requests are welcome!
Dart is already a cross-platform language, and binaries can be easily installed
pub global activate. I'm also hoping that being in Dart makes
it more likely to get contributions from other Dart users!
One potential issue that was pointed out is the possibility of using
switch to a version of the SDK that in turn, breaks dvm. That's a valid
concern, so when releasing
dvm it will ship with its own version of the Dart
VM, similar to dart-sass.
Add this to your package's pubspec.yaml file:
dependencies: dvm: "^0.0.0-alpha"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
|0.0.0-alpha||May 27, 2017|
We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
No platform restriction found in libraries.
Fix analysis and formatting issues.
Analysis or formatting checks reported 3 errors 2 hints.
Strong-mode analysis of
lib/src/executable.dartfailed with the following error:
line: 38 col: 10
The expression in an assert must be of type 'bool'.
Strong-mode analysis of
lib/src/io_helper.dartgave the following hint:
line: 57 col: 13
'UTF8' is deprecated and shouldn't be used.
Package is pre-release.
Pre-release versions should be used with caution, their API may change in breaking ways.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.22.0 <2.0.0|